ArchiveOrangemail archive

Logical Domains Community Discussion List


ldoms-discuss.opensolaris.org
(List home) (Recent threads) (350 other OpenSolaris lists)

Subscription Options

  • RSS or Atom: Read-only subscription using a browser or aggregator. This is the recommended way if you don't need to send messages to the list. You can learn more about feed syndication and clients here.
  • Conventional: All messages are delivered to your mail address, and you can reply. To subscribe, send an email to the list's subscribe address with "subscribe" in the subject line, or visit the list's homepage here.
  • This list contains about 2,601 messages, beginning Sep 2007
  • This list doesn't seem to be active
Report the Spam
This button sends a spam report to the moderator. Please use it sparingly. For other removal requests, read this.
Are you sure? yes no

Error opening VCC device control port.

Ad
Tamer Embaby 1210679938Tue, 13 May 2008 11:58:58 +0000 (UTC)
Hi all,

I'm trying to configure a Sun Fire T1000 machine with the following specs:
Solaris 10 U5
LDom 1.0.2
Sun-Fire-T1000 System Firmware 6.6.1 (Hypervisor 1.6.1, OBP 4.28.1)

I upgraded the firmware to the above version, rebooted, installed LDom 
1.0.2,
then rebooted.  Now when I try to enable vntsd server via SMF:

woody$ sudo svcadm enable svc:/ldoms/vntsd:default

It goes into maintenance mode with the following error in "dmesg":
May 13 13:35:59 woody vntsd[2421]: [ID 266879 user.error] Error opening 
VCC device control port: 
/devices/virtual-devices at 100/channel-devices at 200/virtual-console-concentrator at 0:ctl
May 13 13:35:59 woody svc.startd[7]: [ID 652011 daemon.warning] 
svc:/ldoms/vntsd:default: Method "/lib/svc/method/svc-vntsd" failed with 
exit status 1.

woody$ svcs -xv
svc:/ldoms/vntsd:default (virtual network terminal server)
 State: maintenance since Tue May 13 13:35:59 2008
Reason: Start method failed repeatedly, last exited with status 1.
   See: http://sun.com/msg/SMF-8000-KS
   See: man -M /usr/share/man -s 1M vntsd
   See: /var/svc/log/ldoms-vntsd:default.log
Impact: This service is not running.

woody$ sudo ldm ls
David Finberg 1210680289Tue, 13 May 2008 12:04:49 +0000 (UTC)
On Tue, 13 May 2008, Tamer Embaby wrote: > Hi all, > > I'm trying to configure a Sun Fire T1000 machine with the following specs: > Solaris 10 U5 > LDom 1.0.2 > Sun-Fire-T1000 System Firmware 6.6.1 (Hypervisor 1.6.1, OBP 4.28.1) > > I upgraded the firmware to the above version, rebooted, installed LDom > 1.0.2, > then rebooted. Now when I try to enable vntsd server via SMF: > > woody$ sudo svcadm enable svc:/ldoms/vntsd:default
There is no problem with your setup. The vntsd service can not start until you have a domain that requires a console service. -- Dave
Tamer Embaby 1210688489Tue, 13 May 2008 14:21:29 +0000 (UTC)
David,

Thanks a lot! Indeed I didn't need that, as the file was created after I 
configured
the primary LDom.

I guess the document linked from:
http://www.opensolaris.org/os/community/ldoms...
"Configuring the Control Domain" ->
http://unixconsole.blogspot.com/2007/03/confi...

Need to to change to reflect that as it mention that vntsd has to be running
in the very beginning of LDom configuration.

Regards,
Tamer
David Finberg wrote: > On Tue, 13 May 2008, Tamer Embaby wrote: > >> Hi all, >> >> I'm trying to configure a Sun Fire T1000 machine with the following >> specs: >> Solaris 10 U5 >> LDom 1.0.2 >> Sun-Fire-T1000 System Firmware 6.6.1 (Hypervisor 1.6.1, OBP 4.28.1) >> >> I upgraded the firmware to the above version, rebooted, installed LDom >> 1.0.2, >> then rebooted. Now when I try to enable vntsd server via SMF: >> >> woody$ sudo svcadm enable svc:/ldoms/vntsd:default > > > There is no problem with your setup. The vntsd service can not start > until you have a domain that requires a console service. > > > -- Dave >
Home | About | Privacy